Microsoft Unity 2.1 - May 2011 Release, Aug 2012 Release

Release Notes

Welcome to the release of Microsoft Unity 2.1!

What’s New

This optional service release of Unity (2.1.505.0) contains fixes to the Unity Interception Extension:
For the list of fixes in the August 2012 Update (2.1.505.2) please see this page.

System Requirements

  • Supported architectures: x86 and x64.
  • Operating system: Microsoft Windows® 7 Professional, Enterprise or Ultimate; Windows Server 2003 R2; Windows Server 2008 with Service Pack 2; Windows Server 2008 R2; or Windows Vista with Service Pack 2.
  • Microsoft .NET Framework 3.5 with Service Pack 1 or Microsoft .NET Framework 4.0.
For a rich development environment, the following are recommended:
  • Microsoft Visual Studio® 2008 Development System with Service Pack 1 (any edition) or Microsoft Visual Studio 2010 Development System (any edition).
To run the unit tests, the following are also required:
  • Visual Studio 2010 Premium, Visual Studio 2010 Professional, or Visual Studio 2010 Ultimate edition.
  • Moq v3.1 assemblies.
If these dependencies are not met, you may not be able to use certain features of Unity.

Learning More

The following learning resources are recommended:
See also:

Providing Feedback

Microsoft would appreciate feedback on any issues found, or any other general comments on this release.
To report a bug, use online Issue Tracker. Other feedback or questions can be posted on the Unity Codeplex forum.

Last edited Aug 7, 2012 at 12:37 AM by gmelnik, version 5