Unity 2.1 without .Net 3.5

Jun 11, 2012 at 7:11 PM

We've stumbled across an issue with deploying an application using unity 2.1 on a machine with only the .net 4.0 client profile. Trying to launch the app generates an error about being unable to find .net 3.5 files (obviously) and it originates from Unity.

I've seen other discussions about .net 4.0 and it's mentioned that the 3.5 unity is "binary-identical", but it still seems to want 3.5 libraries.

 

Has anyone worked with targeting 4.0 with unity? Any suggestions?